Page 1 of 1

Board sofware update

Posted: Sun 01 Oct, 2017 10:33 pm
by PuzzleScot
I'd been putting this off for some time, but was forced into action yesterday when our hosts upgraded their PHP version to 7.0x, which was not supported by the current version of phpBB.

Anyway, as you can see, the forum is working, as is most(?) of the rest of the website.

I'm aware of a couple of pages still requiring attention. If you find any, especially if important, let me know asap. Thanks.

Re: Board sofware update

Posted: Mon 02 Oct, 2017 12:25 am
by GarethMoore
There should probably be a way of getting to the main site? I think previously the logo did that, but I wouldn't suggest restoring that. How about linking from the text at the top of the page, under 'UK Puzzle Association'?

Re: Board sofware update

Posted: Mon 02 Oct, 2017 8:37 am
by PuzzleScot
I've restored clicking the logo as a return link to the main website. As you say, not a perfect solution.
There doesn't appear to be any other standard configuration to modify the header banner.

However, it is possible to fully customise the header banner by getting stuck into the /prosilver/template/overall_header.html
I don't have the time right now to dig into this, so the original logo clicking will have to suffice for now.

Re: Board sofware update

Posted: Mon 02 Oct, 2017 9:55 pm
by kiwijam
I panicked when my favourite "active topics" disappeared, but found it in Quick Links, so am happy again.

Re: Board sofware update

Posted: Thu 05 Oct, 2017 12:58 am
by kiwijam
Alan, I went to a Contests page
http://www.ukpuzzles.org/contests.php?contestid=7

and clicked on the link to the puzzle file
http://www.ukpuzzles.org/file_download. ... 957a4f0590

But got this error message:
"Illegal use of $_GET. You must use the request class to access input data. Found in /home/ukpuzzl1/public_html/file_download.php on line 3. This error message was generated by deactivated_super_global."

Re: Board sofware update

Posted: Thu 05 Oct, 2017 8:27 am
by PuzzleScot
Thanks James. That's fixed.
Anywhere that accesses php '$_' variables (GET/POST/REQUEST/etc) are now throwing errors since the server upgrade.

I need to systematically go through all scripts replacing all references. In the meantime, report here anything that can't wait. Ta.